Üye Girişi Yapınız     


    E-Posta
    

    Şifreniz
    



Şifremi Unuttum


Ana Sayfa Site Hakkında İletişim Ziyaretçi Defteri Döküman İndir Makale Ekle Haber Ekle

     EĞER, YADA, VE Fonksiyonları
     admin     03.03.2017     11:51:22

Excel’de sıklıkla kullanılabilecek EĞER, YADA ve VE fonksiyonlarının görevlerini açıklayıp, kullanımlarını birer örnekle açıklayacağım. EĞER fonksiyonu, programlamada if olarak kullanılan kontrol yapısına benzemektedir. İstenilen şartın gerçekleşmesi ya da gerçekleşmemesine göre sonuç üretir. Birden fazla şart olması durumunda YADA,VE fonksiyonları kullanılır.  YADA fonksiyonu EĞER’in içinde kullanılır. Şartlardan en az birinin sağlaması durumunda Doğru değer üretir. VE fonksiyonu da EĞER’in içinde kullanılır ve şartlardan tamamının sağlaması durumunda Doğru değer üretir.



EĞER Fonksiyonu

=EĞER(Şart İfadesi; "Şart doğruysa yapılacak işlem"; "Şart sağlamıyorsa yapılacak işlem")

=EĞER(D2>=50;"GEÇTİ";"KALDI")

Örnekte, ortalaması 59 ve üzeri olan öğrenciler için GEÇTİ, diğer öğrenciler için KALDI ifadesi yazdırılmıştır.

 

YADA Fonksiyonu

=EĞER(YADA(Şart ifadesi-1; Şart ifadesi-2);"Şartlardan birisi doğruysa"; "Şartların tümü yanlışsa)

=EĞER(YADA(B2>=50;C2>=50);"BAŞARILI";"BAŞARISIZ")

Örnekte ortalama değerine bakılmaksızın, iki sınavdan herhangi biri ya da her ikisi 50 ve üzerinde notu olanlar için BAŞARILI, her ikisi 50’nin altında olanlar için BAŞARISIZ yazdırılmıştır.

 

VE Fonksiyonu

 =EĞER(VE(Şart ifadesi-1; Şart ifadesi-2);"Şartların tümü doğruysa"; "Şartların herhangi biri yanlışsa)

=EĞER(VE(B2>=50;C2>=50);"BAŞARILI";"BAŞARISIZ")

Örnekte, ortalama değerine bakılmaksızın, her iki sınavdan 50 ve üzerinde not olan öğrenc, BAŞARILI, sınavlardan en az birinden 50’nin altında not olan öğrenci BAŞARISIZ sayılmıştır.

Facebook'ta Paylaş    
Diğer EXCEL İçerikleri       Tüm Yazılar        Ana Sayfa


  =>Soru Sorun veya Yorum Yazın...

İsim Giriniz :
  

  =>Yapılan Yorumlar...